Wymagania systemowe

By uruchomić GrandNode, musisz spełnić kilka warunków:

.NET Core w Twoim Windowsie

.NET Core jest wspierany przez poniższe wersje Windowsa: 

  • Windows 7 SP1
  • Windows 8.1
  • Windows 10, Windows 10 Anniversary Update (version 1607) or later versions
  • Windows Server 2008 R2 SP1 (Full Server or Server Core)
  • Windows Server 2012 SP1 (Full Server or Server Core)
  • Windows Server 2012 R2 (Full Server or Server Core)
  • Windows Server 2016 (Full Server, Server Core, or Nano Server)

.NET Core na Twoim Mac'u

.NET Core 2.x jest wspierany przez poniższe wersje macOS: 

  • macOS 10.12 "Sierra" and later versions

Visual Studio na Mac

Możesz wykorzystać dowolny edytor, by rozwijać aplikacje .NET Core używając .NET Core SDK, ale jeśli chciałbyś to robić na Macu, możesz użyć Visual Studio dla Mac. 

.NET Core na macOS z Visual Studio dla MacOS wymaga: 

.NET Core wspierany przez Linux

.NET Core 2.1 traktuje Linuksa jako pojedynczy system operacyjny. Jest tylko jeden build dla Linuksa.

NET Core 2.x jest wspierany przez poniższe dystrybucje: 

  • Red Hat Enterprise Linux 7
  • CentOS 7
  • Oracle Linux 7
  • Fedora 25, Fedora 26
  • Debian 8.7 or later versions
  • Ubuntu 17.04, Ubuntu 16.04, Ubuntu 14.04
  • Linux Mint 18, Linux Mint 17
  • openSUSE 42.2 or later versions
  • SUSE Enterprise Linux (SLES) 12 SP2 or later versions

Zależności w dystrybucjach Linuksa

Poniższe zależności są przykładami, poniższe wersje i nazwy mogą się różnić:

Ubuntu

Ubuntu wymaga zainstalowania poniższych bibliotek: 

  • libunwind8
  • liblttng-ust0
  • libcurl3
  • libssl1.0.0
  • libuuid1
  • libkrb5
  • zlib1g
  • libicu52 (for 14.X)
  • libicu55 (for 16.X)
  • libicu57 (for 17.X)

 

CentOS

CentOS: 

  • libunwind
  • lttng-ust
  • libcurl
  • openssl-libs
  • libuuid
  • krb5-libs
  • libicu
  • zlib

IIS 8.0 lub wyższy

ASP.NET Core 2.1

Wspierana baza danych:

  • MongoDB 3.4 lub wyżej

Wspierane przeglądarki:

  • Microsoft Internet Explorer 11
  • Mozilla Firefox 2.0 lub wyżej
  • Google Chrome 1.x
  • Apple Safari 2.x

MS Visual Studio 2017 z ASP.NET Core 2.1 zainstalowanym